Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have been diligently working on my 83 SD to get rid of a rough idle (smooth as silk when moving)! Here is what I did and still a rough idle:
1. 2 new fuel filters
2. Valve adjustment
3. New Motor Mounts
4. New Motor Shocks

It feels like if I increased the RPM from about 750 to 800 it would run better. any suggestions?

Thanks!
 

·
Registered
Joined
·
7 Posts
79 300sd idle rumbling

The 79 300sd I test drove tonight is real solid, but it also has a really rough idle that sounds like the one you all are having. THe whole car shook very abruptly at an idle, and when I gave it gas sometimes it basically didn't have any power, but slowly picked up speed until maybe 15-20 miles per hour at which point it seemed to have power back again. It also died once in traffic. The owner just had a mechanic look at it, who said it was the fuel pump causing the rough idle/dying, but unfortunately it didn't get fixed because there wasn't enough time to do so before the owner was scheduled to show it to prospective buyers such as me.

The car has 166k miles, is very pretty, and he is asking $2000 minus $300 for the fuel pump cost. This seems like a really good deal, and I am about to jump on it. However, a diesel owning friend of mine told me to beware because it could be the "injection pump" as opposed to the "sys pump." (Not sure if it is spelled "sys") ANyway, my friend recommended that I tell the owner I will purchase it if we can take it back to the shop and have the repair done first to make sure that it fixes the problem. This seems like a reasonable strategty to me.

Would appreciate if anyone has comments on the likelihood of this being an "injection pump" probelm as opposed to a "sys pump" problem?

Thanks so much,
-r

ps. the 79'300sd is definitely not too long. 8)
 

·
Registered
Joined
·
9 Posts
It's not the fuel pump- if it was, it would just run worse when trying to accelerate.

Have your mechanic check the EGR sytem- sounds to me like the EGR valve may be stuck open.

Good Luck.

Joe
 

·
Registered
Joined
·
5 Posts
rough idle

your fuel system could be sucking air - check fuel lines. I just had the same problem my leak was coming from my racor filter housing wich had no filter so I by passed the filter - problem. or a rough idle (shaking) can be cause by the rack screw on the back of the injection pump
 
1 - 6 of 6 Posts
Top