Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,

im a new member, and i was hoping someone could advise me on my cars ride. recently, ive been getting a shudder on acceleration and braking. the shudder is felt thru the steering wheel and pedals.

it is not the mountings (gearbox or engine)
it is not the balancing or wheel alignment.

on hot days, no shudder is felt and the car runs perfectly.

my windscreen wiper also seems to be acting up. it works fine but its resting position has changed from the bottom of the windscreen to midway up the drivers side.

any suggestions?
 

·
Registered
Joined
·
1,467 Posts
Flat spotting tires? What kind of mileage do you have on it? Z rated tires? Wheel size? How about excessive play in the drag link assembly or ball joints? Does it occur the entire time when it's cold or just for the first 20 minutes or so? What does the flex disc look like? Does it only occur on accel/decel and not while cruising?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
hi

the tyres are the recommended size and rating. no flat spots and only about 7000km old.

ball joints and bushes were replaced about 4000km ago.

the car only has about 120 000km mileage on it.

the shudder happens on accel and decel and while cruising at a certain speed(about 110km/h) in cold weather. when the ambient temperature reaches about 27celcius or more, the shudder disappears.(i live in Cape Town, so that is about half the year).

ill have the drag link assembly and the flex disk checked and get back to you.

thanx
ak
 
1 - 3 of 3 Posts
Top