Benz Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter #1
Yesterday, just as I arrived home and pulled into the garage, my instrument panel errupted with a stern warning about my ABS and ESP systems and said to get service. I figured I'd deal with it today, but when I got in the car this morning there were no such warnings and even the 2 malfunctions had cleared.

Anyone have this happen? I'm not sure I want to flirt with a possible brake problem. I thought that the malfunctions would stay in the computer until cleared by the service department (guess I was wrong). Or, perhaps I dreamt the whole thing.
 

·
Registered
Joined
·
14 Posts
I was getting those two faults about once every two weeks. I finally took my car in and they did some test and replaced the cable for the ESP control unit.
They said something along the line of being too sensitive.
 

·
Registered
Joined
·
3 Posts
I had the same problem, except I took it to the dealer right away..they fixed the problem and the sunroof would not open, so they had to replace the control panel...
 

·
Registered
Joined
·
3 Posts
I had the same problem, except I took it to the dealer right away..they fixed the problem and the sunroof would not open, so they had to replace the control panel...
 

·
Registered
Joined
·
36 Posts
I had it fixed by northhaven merc

They replaced a wire harness and it fixed the problem if you need the info. i may be able to get it. 8O
 

·
Registered
Joined
·
26 Posts
It is happening to me aswell, dealer assured me its a sensor problem and everything is fine. I also get rear license plate light is out displayed but it is working fine. Isnt technology suppose to make life easier heh!
 

·
Registered
Joined
·
34 Posts
This happened to me as well

The BAS/ESP warning, if it's occasional, is not a serious problem.

It used to happen to me at random until I brought it in and they determined that the sensor was being too "sensitive". The service technician actually said that the placement of the sensor was causing it to pinch against something, thereby triggering it.

Also, if your sunroof won't open, it probably just needs to be recalibrated. It happened to me after I got my car back from being repaired. My guess is that they reset the computer in some way and it lost the setting. *shrug* In any case, recalibrating is easy to do. Just check the manual (not the quick reference booklet). It just involves holding some buttons down for 10 seconds or so.
 

·
Registered
Joined
·
2 Posts
Solution

:D
I had the same problem a few months ago in the summer this year. The Benz dealership got tired of me coming back 4 times due to the same warning display. The first time, they had said that the wires were too close to one another therefore triggering the onboard computer to think that the brakes were malfunctioning. In most cases, if you turn off your car engine take out the key, and restart the car, the warning display will go away. If you truely cannot do this everytime that your car says that it needs repairing. TAKE IT TO YOUR DEALER like i did.. They MB people did a research and said that it is very common and there was a problem with their system. So they will have to replace the entire System.
It'll take a few days for them to order it and place it into your car.
Yeah i know. it sucks..
 
1 - 14 of 14 Posts
Top