Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Im having the issue where the alarm siren goes off randomly with the lights flashing. Also getting can bus communication errors. also the 20amp alarm fuse keeps popping.

1.)First I replaced the service battery with a new one just to rule that out.
2.)Replaced with brand new siren and the problem still occurs.
3.)The alarm sounds off while the lights flash. I am at a loss on what to do next or even attempt. Siren code cleared and has not come back on my scanner. what else could it be???
4.) went through every single fuse in the car 1 by one to verify a popped fuse.

I am using a autel maxis scanner. There are can bus related problems and sam module errors. If someone can guide me on what to do next that would greatly appreciated. I have scoured the forums any related issues to no resolve yet. Someone help please!!! Dealer wanted me to replace all the sam modules prior to this issue even happening when I couldn't get the locking system to work, but I ended up figuring out the fuse solved that.

codes stored and current
B1021 stored/current - control module A37 (PSE(pneumatic control module) is not sending data on the can bus
b1638 stored - the component and/or signal wire to the components k40/4kp (fanfare horns relay) has short circuit to ground
b112d stored/current - Fault in CAN communication with the control module N60 (central locking (cl/zv)control module

there are a ton more but this are the main related codes that im seeing thats tied to the issues.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
To quickly update on my status. I removed the the rear sam module behind the the passenger seat under the little compartment and disassembled it and cleaned all contact points that showed any corrosion. I was hoping that would fix my issue, but I am still facing the same issues. As soon as I put everything back together and replace locking fuse the car locked then soon after the siren starting going back off again. Then I could not lock the door anymore with the remote so I check the fuse and it is blown again. As far as I know i keep replacing it with a 20amp fuse and do not plan to go bigger unless someone else knows for sure that it is rated for a higher rated amp. Anymore inputs would greatly be appreciated!!!



Ive read around that i can purchase a used sam module and just reprogram it to my vehicle? can someone confirm this. I am sure my scanner is capable of programing a new module.



also I forgot to mention that I am having tail lamp faults left and right and license plate faults as well.

I have also replaced the pse pump way back as well so and it did not fix any issues.

Should I proceed to remove the driver front sam module and clean those contacts as well? and just to make sure the driver front sam module controls the alarm system on a 2004 sl500??
 
1 - 2 of 2 Posts
Top