Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Greetings good people!

I am a new member here but, not new on working on cars. I have what you may say the hard knocks of helping out my Family and Friends with their cars and taking some time to share a specific experience with you all on my friend's 1997 Mercedes-Benz C230 sedan.

For starters, he bought this car almost 4 years ago and a few repairs to it, however, this C230 came with 16 inch Mercedes-Benz Rims from the 2001-2004 vintage. Certainly, the stock rims were 15 inch but, the car rides okay..........................

Fast forward to today, the C230 logged 245,000 miles approximately because it's on the 2nd or 3rd Instrument Cluster. My friend was told by a family member that the brakes were needing to be replaced (Hogwash). His brother insisted saying that the peddle was low and it sounded like the brakes required changing. Well, after a while my friend got so tired of his brother complaining that he did. He went to the local Auto Parts Place (NOT A MERCEDES PARTS STORE) and they handed him yet another pair of Rotors and Brake shoes for the front.

On a personal note, my good family friend's eye sight has been failing really bad and his does things with his fingers and failed to noticed the securing bolt that secures the Rotor-to-Wheel Hub. He took OFF the old Rotor and installed the new Rotor on TOP of this securing Bolt and torqued down the rotor and assembled the Carrier with the new Brake Shoes etc....etc..... Of course the C230 went down the road exhibiting the following:

1. Visible Shaking above 35-MPH (At First it was not that bad but, it got progressively worse every time you went out with it).
2. After a while the Front Brake Pads started to make a Tweet Sound like if the new rotors were out of round.
3. After almost two weeks I got involved and took it out to test drive it and decided to get an alignment (What a mistake that was! This car started shaking really bad to the Alignment shop! )

Upon further inspection, the new and OLD rotors were NOT the correct rotors for this 1997 C230.

Why?

Because according to the VIN Number, this particular C230 was assembled near the end of 1997 and tooling at the factory was already geared UP for 1998 C230 model and Brake parts (Rotors) was from the 1998 C230!

The awful vibration and shaking going down the road caused a few items to go, such as:

1. The Steering Damper.
2. The entire Tie Rod End "Steering" Assembly.
3. My friend's wife ended up at the curb during a slow right turn because the steering wheel went on it's own and turned the car quickly during a right hand turn (Ruined the 16-inch rims on the passenger side).

Needless to say, this issue has been an Expensive Lesson we all can take to the bank and let's say that we all need to remember to take the VIN number with us when trying to find Parts for our C230's! The trouble here was that my Family Friend went to a Auto Parts Store that DID NOT ask for the VIN and they just went by the year (1997) causing an ugly situation by having someone who was going blind perform brakes with holes that didn't align and thinking that the Securing Bolt was there for the Wheel Hub and not realize that there was something very wrong! Of course HUMAN ERROR was at fault here but, I am certain if the AUTO PARTS STORE would have asked for the VIN, they would have given him the correct rotors and I am certain that ALL THIS would have been avoided.

I have helped them replace the entire Tie Rod "Steering" Assembly and the correct Rotors (From a Reputable AUTO PARTS STORE that did ask us for the VIN).
Replacing the entire Tie Rod "Steering" Assembly was pretty challenging to say the least as we don't have a lift and we did it in his garage. It was an amazing 6 hours of work!

A few Pictures (First couple of pictures is his wife that had to learn mechanics in order to keep my good family friend out of trouble!)

Thanks for your time and attention and do hope this post would help someone.:laugh:
 

Attachments

1 - 2 of 2 Posts
Top