Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a '96 E320 that has been giving me trouble. Before I bring it to the dealer I'd like to know if anyone has had similar problem. The ASR warning light has been coming on and whenever that comes on the car seems to just dropped down in gear or the throtle is not giving out enough gas for it to accelerate. What's causing that? I've recently changed the tail lights to the 2000+ model and ever since the change the ASR has been coming on. I know it's silly, but that has nothing to do with it (I hope!). What to do, what to do? Please help.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Clarification

The exact message I get from the control module is:

ASR ACC.SKID Control

Anyone else have had this problem?[/b]
 

·
Registered
Joined
·
678 Posts
Sounds like it's gonna be needing some diagnosis. Possibly CAN communication failure between your ASR and engine control module.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Found Solution

This is a strange car. As I said on my first post that I had changed the tail lights to after market designs. I have 2 bulbs that weren't functioning properly because the aftermarket lights are poorly designed where some of the lights were not making good contacts with the metal part. I replaced the lights back to original tail lights and the problem went away. I guess it is a safety measure that MB incorporated to the computer saying that you shouldn't be driving the car with only some tail lights working. But, it was also dangerous when you 're driving when all of a sudden your car just dropped in gear and refuse to run faster than 5 mph.
 
1 - 4 of 4 Posts
Top