Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Can someone please tell me the exact location of the K57/2 Aux Relay. What do I need to remove to get at it. Thanks!!!

Greg
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
2008 SL55

It is not the k57 in the trunk.

Everything i read says its in the engine bay. Is is up against the firewall? Remove the windshild wiper panel. (Bolts hidden, or some sort of slid-up?)
Or could it be in the pass fender well? For this remove the tire and plastic fender well.

thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks, I may have the wrong part?
Some of the web post I see say two K57 relays, one in front and one in the rear.

In the end, the Aux Bat in the front is not charging just after starting like it should. I should see my meter go from ~12.5 to 14V just after start. Alt seems to be fine at 14.2V after start, and both bats are new (front and rear). The web pointed me to the AUX bat relay.

I have the Batt. message on the dash.

SL55 2008
 

·
R.I.P Always Remembered
Joined
·
1,865 Posts
Thanks, I may have the wrong part?
Some of the web post I see say two K57 relays, one in front and one in the rear.

In the end, the Aux Bat in the front is not charging just after starting like it should. I should see my meter go from ~12.5 to 14V just after start. Alt seems to be fine at 14.2V after start, and both bats are new (front and rear). The web pointed me to the AUX bat relay.

I have the Batt. message on the dash.

SL55 2008
Have you had the fault codes read out?
 

·
R.I.P Always Remembered
Joined
·
1,865 Posts
Have you had the codes read out yet? I searched both WIS and star finder and there does not appear to be a K57/2 on your car, only the K57 Battery lockout relay in the trunk.
 
1 - 9 of 9 Posts
Top