Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Our 1995 E420 just randomly stopped starting. We drove to our destination came back to the car to leave approx 2 hours later and it would not start. The battery and everything seems to be fine. All the electronics work, it just won't turn over. Any ideas?
 

·
Registered
Joined
·
1,467 Posts
124 car not starting? Hmm, with that type of issue I would suspect replacement of the overvoltage protection relay and the fuel pump relay would be a good place to start. They tend to have similar lifespans and can cause similar issues, so we normally replace them together. If that doesn't help you're going to need a bit more in depth diagnosis (insert dealer plug of your choice).
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
PHAEDRUS242 said:
124 car not starting? Hmm, with that type of issue I would suspect replacement of the overvoltage protection relay and the fuel pump relay would be a good place to start. They tend to have similar lifespans and can cause similar issues, so we normally replace them together. If that doesn't help you're going to need a bit more in depth diagnosis (insert dealer plug of your choice).
Thanks, we'll try that first. :)

Now, are there any places that offer good deals on them? :D Or should I just get it from the dealer? :(
 

·
Registered
Joined
·
1,467 Posts
I hear importpartsonline.com (our sponser, conveniently enough) offers pretty good deals on such parts. Plus you're keeping this forum open with you're purchases.
 
1 - 4 of 4 Posts
Top