Benz Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
I have a 2000 C230 Kompressor with a little over 100K miles on it. The check engine light came on. Again. And again. This is the fourth time. The first three times, the dealer said it was the oxygen sensor, and they replaced it. Then they said there are two oxygen sensors, and they replaced the other one. Each time, only around 150 miles went by before the light came on again. According to CT law, I can press for the lemon law at this point, but I really don't want to have to go that route. It increases the inconvenience and frustration level even more.

What could it be? I think that it's something that relates to the sensors, more in line with perhaps a failure of the supercharger, but I'm just guessing at this point. Anyone have any ideas?

I talked to the dealer, and if I give them one more try they are willing to add an additional year/12000 miles to my warranty, which I think is very fair of them.
 

·
Registered
Joined
·
127 Posts
Sound like a fair deal, an additional year warranty is like a grand or so. In my 2002 C230 I had to have the ECU (Electronic Control Unit) replaced at about 10K when the "Check Engine " light came on. As long as you are not getting stranded and they give you a loaner when they do the repairs, I'd give the one or maybe two more chances. If they can't fix it at least you have a years warranty to sell with the car a value added item, make sure it is transferable.

Good Luck
 
1 - 6 of 6 Posts
Top