Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Whenever it wants to.

A few days after I bought my new C320 Coupe, going down the highway with cruise control engaged, it disengaged itself. No problem. I just pulled the little lever back, accellerated a little and we're back in business. Unfortunaetl this phenomenom occurs about every half hour. On my first trip to the dealer for routine maintenance I reported the problem, but they could find nothing wrong. The problem still occurs from time to time, and the second time I brought it in for routine maintenance, I again reported the problem. Nothing comes up with diagnostic testing, because you can't force it to fail. (Sorta like in the the old days when the TV repairman came to your house, and if the TV was no longer acting up, there was nothing for him to fix.) So do I have to live with this problem? Anybody else have the same problem or any ideas?
 

·
Registered
Joined
·
1,467 Posts
Yeah, that's about all that really goes wrong with the cruise control system. I'm willing to wager you have a stored code present for "stop lamp switch occasionally implausible". Have it checked out again, or just buy a switch and change it out yourself if they seem unwilling to help. The switch is under $20 even at your most expensive dealer and should take no longer than a couple of minutes to change out.
 

·
Registered
Joined
·
1,467 Posts
The switch goes at the base of the brake pedal itself. You can remove or "fold back" the lower panel on the driver's side. A flashlight is helpful to see what's going on down there. You'll see up on the brake pedal where that switch is. You twist the sensor and pull it right out. On some of the cars, the wires appear to be interchangable. Be sure to keep them in the correct order. Just to be on the safe side, I would always leave the sensor plugged in until I had the new one installed, then used it as a direct referance. That way, you don't even give yourself an opportunity to mess something up. It's pretty straightforward. If you run into any snags, let us knnow and we'll do whatever possible to help you out. It should be a piece of cake.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
Thanks! So yesterday I put 300 country miles on my C320 Coupe and my cruise control continued to frequently disengage itself. Several times I had two malfunction codes come on at the same time. One said ESP and the other BAS. By pulling over and turning the ignition off and restarting, the malfunctions went away and the dash said "No malfunctions" instead of "2 Malfunctions." Does this mean the problem might be somewhere besides the brake light switch (which I still haven't picked up yet)?

The indicator also said to go to the workshop!
 

·
Registered
Joined
·
1,467 Posts
This happening only convinces me more that it is your stop lamp switch. I would bet dinner at Morton's on it. Now that you've had the warning come on, there is definately a stored code in your module, so the dealer would have to replace it under warranty.
 

·
Registered
Joined
·
1,467 Posts
Lynn's right, there is a wiring harness update on the ESP module. The purple, brown and blue wires going directly into the unit can oxidize and cause ESP/BAS warnings to appear. If this is the case, the Star tester's code will actually mention the TSB in it's description. The stop lamp switch is far more likely, but that wiring update is probably the second most common fault.
 
1 - 9 of 9 Posts
Top