Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
:) HI ALL..IM NEW HERE...AND WOULD LIKE TO HAVE SOME ADVISES FROM YOU EXPERTS..I JUST BOUGHT THIS USED 03 ML320..ONLY 15K MILES..DRIVE IT FOR FEW WEEKS..IT SEEMS REALLY GOOD AND SMOOTH ON HIGHWAY EXCEPT FOR THIS CONCERN..IT PICK-UP VERY SLOW AFTER STOP SIGN OR RED LIGHT..(GOT HONK BY PEOPLE BEHIND) I DONT KNOW IF THIS IS A NORMAL CONDITION FOR MERCEDES OR NOT (NEVER HAD ONE B4)...IN OTHER WORD..IT SLOW SHIFT AND SEEMS LIKE HAS A RESISTANCE AT ACC. PEDAL (TOOK ABOUT 20-30 SECONDS TO REACH 60MPH..PLEASE HELP!!!THANKS
 

·
Registered
Joined
·
27 Posts
Check engine light on? Have you checked the egine for any codes, or is the engine cooling fan making alot of noise? Possibly a mass air flow sensor, frozen fan clutch...maybe..
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Hi again,

Thank you very much for your respond mbTech..the car smell just like new :) and no lights are on dash as well..the previous owner said he had a new throttle cable replaced..(because it was sticky) that's it..it runs very smooth and no problem at highway speeds..but it has to take a while to reach to that speeds (about 60mph or over) unlikes other asian SUVs..their speeds pick-up quicker..it's hard to explain clearly...just think it this way...on the race track...it will be left way behind by other SUVs for quarter mile ... :) specially occures after stop sign or red light (vehicle stopped)..short gas pedal..if you keep pushing harder, then you feel like the pedal stops (wont go down further). everything would be nice and smooth as it reaches above 60 mph. (enigne runs smooth and quiet)
 
1 - 3 of 3 Posts
Top