Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Ok, in the process of replacing fuel lines today, I noticed that this thing here wasn't connected. I don't know if I knocked it loose while working, or if it came loose while the engine was running (quite likely as the engine, being a diesel, shakes a good bit, and this thing is REALLY loose)

http://www.4amlunch.net/pics/v/wonko/300SD/engine/VacuumThingie.jpg.html

The short little piece of hose (very similar to the injector return line hose) is very old, brittle, dry and cracked, and has no holding power.

This should definitely be replaced. I did trace where this all connected to, as I'm the curious type. I'm glad I did, because this is what I found:

http://www.4amlunch.net/pics/v/wonko/300SD/engine/ThottleThingie.jpg.html
http://www.4amlunch.net/pics/v/wonko/300SD/engine/BrokenVacuumLine1.jpg.html

First of all, what exactly *is* that thing? Is this something I should be very concerned about and replace that vacuum line ASAP, or is this the sort of thing that I can just plug up and get on with my life?

also:

http://www.4amlunch.net/pics/v/wonko/300SD/engine/VacuumTube1.JPG.html

That vacuum line is somewhat kinked, and it looks like it melted a bit there, and probably got soft enough that when pushed into the valve cover breather tube, it got squashed. Should I also replace this?

-brian
 

·
Registered
Joined
·
172 Posts
I will buy you a bottle of GUNK...make that two bottles. That valve cover looks filthy. I don't know much about vacuum except for the one that I (rarely) use on my carpet.
 
1 - 3 of 3 Posts
Top