Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I recently bougt an '01 E320 and have a question on the fuel tank display. Before gassing the car last night display indicated approx. 5 gal in the tank with gas gauge at about 1/4 which seemed about right. With a 21 gal tank I was expecting to put about 16 gal into the tank. It only took 12 and the display now tells me there is 17 gal in the tank with the gauge now reading full. The math all makes sense but i seem to be 4 gal short of where I should be.

Appreciate any thoughts on what might be going on here, thanks.
 

·
Registered
Joined
·
77 Posts
On a used car that you don't know if the owner was completely fulling of gas his car, that can happen. That may be a sensor problem in the tank and maybe you can cure this by fulling many times your new car. I had such a problem lately after my car was left a few weeks its tank less than half full. After that, the cluster would not indicate that it was full, even if I couldn't pour more gas in. The dealer told me the sensor was to be replaced but I tried the trick I just told you: To full the tank many times in the next few weeks. To do so, I did have to travel a lot and it did repair the sensor well enough. The sensor travel on an articulation and this can become corroded with time and not making its full travel will not help (not fulling the tank). I think your problem is a lesser problem than the one I had. All that is based on my own experience, since I'm not a registred mechanic.
 
1 - 2 of 2 Posts
Top