Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Red battery, engine, ABS, and ESP lights and warnings going off, power steering issues, window buttons not working, some shaking, and weak acceleration and little to no reverse ability (sometimes!). Even the AC started to not work some days this week, but was working today during all this. Plus, today the COMMAND unit was completely off for the first time. I believe I also saw the coolant light show up on the speedometer screen momentarily. I even felt the ABS not work in the brakes. Also, the car actually cut off during the drive but we were able to restart. Luckily we were close to home and able to drive back, called MB Roadside and had it towed to the dealer. Any clue what's up? Thanks in advance, and hope everybody is well and safe!
 

·
Registered
Joined
·
6 Posts
Weak battery, dirty connections on the battery possibly a bad ground. Computer controlled cars hate low voltage and you can get all kinds of weirdness going on when it happens.
 

·
Registered
Joined
·
89 Posts
That's pretty hard core so I hope it's only the batt, I've never had one do that with low voltage, but I'd imagine it's possible.
I've been reading some about the CAN system (Controller Area Network which all the little electronic boxes in the car use to talk to each other) and it seems it can get screwed up pretty easily. It's supposed to be robust but appears that the devices on the network, when they go bad, are what end up causing most all the problems. To make it worse, they keep adding more and more things to the system which just increases the odds of failure, and making it harder to find the box that's causing it.
Whatever it is please let us know so the next person has something to go on and we can all learn a little.
 
1 - 3 of 3 Posts
Top