Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello, all, just found this forum and joined.

I just replaced my '85 300D turbo 190K with a 2000 E320. What a difference 15 years makes.

Anyway, the climate control is a bit flakey. It works ok, but I hear a soft high-piched squeal at times and the fan motor is starting and stopping over and over again - like it's trying to turn up to a higher level but can't. The motor will run on high if I manually run it up higher, but in auto it cycles on and off a lot.

I read in another thread where vacuum leaks can occur and cause problems. Without a service manual, is there a way I can find the hoses and look for leaks? I haven't started to investigate how to get up under there from the inside.

I also have a lamp fault. I just replaced a dead right side marker lamp today but that didn't clear the fault. All other lamps I can find are working. Could it be standing lamps? Guess I ought to figure out where they are, eh?

There is one lamp (I think just one) out in the instrument cluster to the left of the speedometer. Is it replaceable by me? If so how and with what kind of lamp?

I can't find anything else wrong with the car - it's just wonderful.

Thanks for some input if anyone has any. Otherwise, thanks for your time. I'll probably want to talk some more as time goes by.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Update to above (lamp fault indicator)...

I found the two parking/standing lamps in the front highbeam housing were both burned out. I can't find replacements at the local autoparts stores, or Walmart (where I found the side marker W5W).

Still wondering about access to the area under the dash for the instrument lamp and climate control vacuum hoses - but haven't actually gotten down under there to look yet.
 

·
Registered
Joined
·
453 Posts
importpartsonline.com

You can find parts for your 2000 E320 on our online parts catalog. If you look up your vehicle by year, make, and model, you can then do a keyword search for "light bulb" to see the bulbs available for your car.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Thanks, (whatever your name is),

Tried that, and that particular lamp is not listed. Guess it's an OEM only kind of thing.


[edit] Got 'em. The fault display is cleared.
 
1 - 4 of 4 Posts
Top