Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Heya everyone, I just inherited a 1983 240D and it's transmission problem.

It's a manual tranny, and it's stuck in 1st gear! Awhile before the problem surfaced, I had pulled the engine to be rebuilt. I remember disconnecting some of the linkage, etc, but it all worked perfectly after I put it back in. My dad was driving it awhile back and was turning a corner trying to shift from 1st to 2nd and it just stayed in 1st and the shifter doesn't move. In the past, it has popped out of gear, but on a very rare basis.

I haven't had the time to take it apart yet, and was curious if anyone here has had the same problem or might have some advice.

Thanks!
 

·
Registered
Joined
·
64 Posts
I know this isn't a direct reply to your question, but...I have an '83 240D parts car with a manual transmission. The car came with no engine, and I don't know the condition of the tranny. I'd be willing to "let go" of it rather cheaply. If you think you might be interested, please let me know.

Thanks.
 

·
Registered
Joined
·
2 Posts
I have seen the same problem a few times on a 1975 240D and it always turned out to be a problem with the linkage. Check it over thouroughly before considering that your transmission is no good. If the linkage is all connected and appears correct you might try and pull one link off at a time and reposition the lever on the tranny one click in either direction, then reconnect and see if there is any change. Its probably a good idea to try your best to remember the original position of the levers on the transmission and place them back there each time if no improvement is made.

I am not an expert but this has worked for me in the past.
 
1 - 3 of 3 Posts
Top