Benz Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello! I'm here today specifically for help with my grandpa's 2007 S550 4matic (~89,500 miles).

We went on a drive, and what seems to be separate systems started going haywire.

Red battery, engine, ABS, and ESP lights and warnings going off, power steering issues, window buttons not working, some shaking, and weak acceleration and little to no reverse ability (sometimes!).
I even felt the ABS not work in the brakes. Also, the car actually cut off during the drive but we were able to restart. Luckily we were close to his house and able to drive it home, called MB Roadside and had it towed to MB Manhattan.

First symptom seemed to be the red battery logo appearing earlier this week. Next symptom was the AC. Only this past week it chose to not work some days. It did work today of course of all days while this commotion was going on. Also, today was the first time the COMMAND went completely blank.

It's really a strange phenomenon. I guess after 13 years with little problems, we knew this day might come.
Hopefully, it's not as expensive as it seems to be or as complicated of an issue.
Please note that after a restart, it sometimes operates fine.
I have a feeling it's computer related.
My dad thinks it's as simple as the belt and said I should've waited for him to come see it before we decided to tow it lol.

Any guidance would be appreciated! I'd like to have some background knowledge before the dealer calls me about the situation tomorrow.

It's also due for Service C in 15 days.

Also, if anyone has any good experience with third party extended warranties, I'm interested to learn more!
My grandpa got the extended warranty from Mercedes at the time, but of course it's expired at this point.
I don't believe there was even an option to get another one from them after that.

Thank you very much, and I hope everyone is well and safe!
 
1 - 1 of 1 Posts
Top