Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Well, its a 300D Turbo year 87. It runs fine and all, but when the car is running and i suddenly break, i hear a loud striking noise coming from the front of the car. It sounds like metal. It seems that the blades cooling the radiator are touching the rad while spinning.

Is the rad to close to the blades?

Any help would be apreciated
 

·
Registered
Joined
·
584 Posts
First time I have heard of that happening for this model car. What recent services have you had?

If the radiator has an arc pressed or cut into it (probably at the top), then it is being hit and definitely too close. To check, there are two clips holding the plasic fan shroud to the radiator. Take thos off, and pull the fan shroud away from the radiator and see what you can find. While you are in there, also make sure that the fan is mounted appropriately to the engine, with no backward or forward play.

If there is damage, and the fan is properly secure, then possible culprits could include bad motor mounts, wrong fan and/or clutch, or both.

When re-installing the fan shroud, be sure that the tab at the bottom slides into its mating surface.

Please follow up, I'm curious about what you will find.

-Neil
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Ah! Fixed it. Someone had backed into the front of my car, kind of pushed things behind the bumper backwards. I tied the front to a tree and slowly backed up to get it straightened out. No more clanking. It was definitely the fan scraping the radiator.

I'd post pics of the whole process if I had a digi cam. Thanks anyways
 
1 - 3 of 3 Posts
Top