Benz Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
I'm not positive my windows did it before but I was sure they had the one touch-up feature as well as the down. It seems all of a sudden the one touch-up doesn't work and the sun roof closes fine but only open one inch at a time. Any ideas?
 

·
Registered
Joined
·
56 Posts
Discussion Starter #3
Never heard of such a thing. How do I do that? Thanks again for the help with the battery drain, it's nice to go out in the morning and know my car will start.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #7
Didn't know about the ESP either. How do i know if it's set? Anything else besides ESP and the windows and sunroof?
 

·
Registered
Joined
·
678 Posts
Whenever I unplugged the battery on a car like yours with an AAC system with stepper motors, I usually resynchronize all of them as well. It really doesn't NEED to be done, but I do it anyway. You can do this by simultaneously pressing and holding the defrost and recirc buttons. You'll see the LED's flash on your pushbutton unit. After about 10-15 seconds, it should stop. Everything should be resynchronized. If they don't stop flashing, you have a problem with one of your stepper motors or linkage.
 

·
Registered
Joined
·
1,467 Posts
Zewerr said:
Whenever I unplugged the battery on a car like yours with an AAC system with stepper motors, I usually resynchronize all of them as well. It really doesn't NEED to be done, but I do it anyway. You can do this by simultaneously pressing and holding the defrost and recirc buttons. You'll see the LED's flash on your pushbutton unit. After about 10-15 seconds, it should stop. Everything should be resynchronized. If they don't stop flashing, you have a problem with one of your stepper motors or linkage.
I have seen quite a few problems caused by not re-synching the stepper motors. This is highly recommended.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #11
I pushed the buttons and they started blinking back and forth and then stopped so they should be good. The ESP the other person mentioned did say it was not working after I restored the power but it went off after I drove and restarted. I assume it must be fine now also. Thanks again!
 

·
Registered
Joined
·
678 Posts
Yeah, the ESP light comes on after the battery is disconnected because the steering angle sensor needs to be learned. After the steering wheel gets turned lock to lock a couple times the car will then know where the steering wheel position is and shut the light off. It does of course store a code, but I wouldn't worry about it.
 
1 - 12 of 12 Posts
Top