Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
I had a small dent removed just behind the rear door on the wheel arch on my 2004 C230. When I got the car back, the radio stopped working. Everything lights up and everything mechanical works but no sound. It also doesn't recognize the CD changer. No sound from radio, CD changer or tape player. Any clues what could be wrong?
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
Thanks Wingless. It would be an expense experiment to try, since that tiny little dent cost me a $1100 to fix. What is the route of this optical cable? Is it any where near the rear fender?
 

·
Registered
Joined
·
38 Posts
Discussion Starter #5
Thanks Lynn:
Is it possible that the radio needs a security code to be re-activated, assuming the battery was disconnected.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #7
Thanks Guys for all your help. I will have to contact the body shop on Monday with this information. It sounds like a messy situation to resolve. I will let you know how I make out.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #8
This morning when I went to use the car, the radio was working again like nothing had happened. Very strange.
 

·
Registered
Joined
·
94 Posts
My radio is a real lemon.
When the temperature riches 80F it stops working for a few seconds and works again for a couple of minutes and so on. At MB they are not able to diagnose the problem....
 
1 - 9 of 9 Posts
Top