Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I recently purchased a used 2004 C240 Wagon for my wife. Car has ran like a champ for three weeks. Recently a rattling noise has started under the car, getting louder when stopped but goes away ( or cant hear it) when driving. The car has 17K miles on it and under warranty. Could it be the cat converters shot already? Any other possible causes? Car drives fine and fuel mileage seems to be non impaired. If cat converter is the problem, is this common on a 04? Thanks in advance.
 

·
Registered
Joined
·
95 Posts
I'm not sure what is common to C 240 wagons, but I had a similar experience with an MB a couple years ago. The rattle was present during start up and idle but disappeared upon acceleration and cruise. Make a long story short, I found that an internal baffle in the muffler had come loose. Sometimes they're really difficult to find. Good luck.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
thanks,

THanks,I am hoping it is something easily diagnosed and corrected by the dealer this week. And hopefully under warranty since the car is so new.
 

·
Registered
Joined
·
95 Posts
Yes, with the car having only 17K miles, I doubt whether it is the cat. Although don't rule out an external bracket. The only way to diagnose is to lift the car and look, feel and shake. (Sounds like a date I once had.) 8O
 

·
Registered
Joined
·
678 Posts
Yeah, every once in a while you get an exhaust hanger that's loose from the factory. Probably a simple fix. Definately should be covered under warranty, unless you've been getting your car airbourne on a daily basis!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Blast from the past....

Yes, you were correct. Both cats had to be replaced. Free charge though. Car still running like a champ and wife is happy for once.
 
1 - 8 of 8 Posts
Top