Benz Forum banner

1 - 20 of 53 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Hi! Got the AC problem with the S400 Hybrid.

There are lots fault coming on.

- The flower motor running and stop, run again and stop by itself.
- No air out to the front air vent.
- The flower speed does not correspond with the selection on the screen.
- LIN, BUS and power supply look ok.
- Temperature at component A32N1 blower regulator (-40).

Please see the print short.
 

Attachments

·
R.I.P Always Remembered
Joined
·
1,865 Posts
Pull the blower motor and test it, I think it has failed. And I know English is not your first language but you do very well with English, however it is Blower and not Flower.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #5
Hahaha! Wrong spelling mate. It's became the flower. Ahahahha.

The blower is turning all the time when engine start without the command and it's same speed. But the blower is on and off when just ignition on.

What do you mean but pulling out the blower? How can we know if the AC system working or not if we pull the blower out?

Thanks for respond mate!


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
38 Posts
Discussion Starter #9
Do you mean the pressure in the AC system line? I did it and it confirm enough refrigerant.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #11
The fault keep asking me to check the cable and supply to the regulator blower and I can see all are supply correctly. Once I replace the new regulator then it did not make any change.

All three codes does not point out to check any other area beside the regulator.
 

·
R.I.P Always Remembered
Joined
·
1,865 Posts
The fault keep asking me to check the cable and supply to the regulator blower and I can see all are supply correctly. Once I replace the new regulator then it did not make any change.

All three codes does not point out to check any other area beside the regulator.
I have just traveled half of China in five days and am tired so better I re read this thread in the morning and think a fresh.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #20
Hi! i have checked and it is connected well. In the actuation data it is also showing correct temperature of current temperature which is about 29 degree.

Do we need to do any adaptation when replacing the new blower regulator mate?

This car was hit by mototorbike on the front right door and it should not affect the AC system... I cannot understand that.
 
1 - 20 of 53 Posts
Top