Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
I recently had the dealer install a thrust arm. front passenger side lower. within two months the bushing on the frame side is torn again. Does anyone else have this problem. if so any aftermarket replacements out there that address this. It's obviuos mercedes doesn't want to.
 

·
Registered
Joined
·
1,467 Posts
I would get t swapped out on parts warranty/ It is possible it was just a bad part. GO from there and see what happens. You shouldn't have to pay anything for it. I haven't seen these fail that quickly, so I would point the finger in that direction first. If it happens again, it is possible something in the suspension geometry is off, or perhaps the subframe is tweaked a bit. Has the car had any front end damage, hitting curbs, etc?
 

·
Registered
Joined
·
33 Posts
rzleo said:
I recently had the dealer install a thrust arm. front passenger side lower. within two months the bushing on the frame side is torn again. Does anyone else have this problem. if so any aftermarket replacements out there that address this. It's obviuos mercedes doesn't want to.
The instructions for installation of the thrust arms specifically state that the suspension must be normally loaded BEFORE and DURING tightening of the bolts holding the thrust arm to the frame and to the hub/bearing carrier.

If the dealer mechanic tightened the mounting hardware with the car on the lift, the result would be that the bushing would be under tremendous stress once the car was lowered off of the lift - resulting in almost certain premature failure.

I'd go back and discuss it with the Service Advisor. Ask him to show you the shop manual with the replacement procedure for the thrust arm (I've got a copy of the W124 manual, but not the W203), and show him that the failure is most likely due to the mechanic not following the explicit directions in the manual.

Good luck.
 
1 - 3 of 3 Posts
Top