Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Both batteries charged, keyless entry/start fobs have new batteries. has the keyless push start option. Tried both keys and even inserted in ignition swith too. Everything works but wont start. Just goes "click" and shows a pic of battery in dash and says see dealer/mechanic on opposite dash screen. Has only 35,000 on it. The car is in park. Could the neutral safety swith be out or the sensor for the brake pedal that must engaged prior to start. A fuse? If so what fuse to check? theres alot of them. I'm hopeing its something simple? otherwise a tow bill and trip to the dealer arrrrg. Thanks all help much appreciated!
 

·
R.I.P Always Remembered
Joined
·
1,865 Posts
Both batteries charged, keyless entry/start fobs have new batteries. has the keyless push start option. Tried both keys and even inserted in ignition swith too. Everything works but wont start. Just goes "click" and shows a pic of battery in dash and says see dealer/mechanic on opposite dash screen. Has only 35,000 on it. The car is in park. Could the neutral safety swith be out or the sensor for the brake pedal that must engaged prior to start. A fuse? If so what fuse to check? theres alot of them. I'm hopeing its something simple? otherwise a tow bill and trip to the dealer arrrrg. Thanks all help much appreciated!
Both batteries charged, but does the starter battery hold it's charge? have the battery tested.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Both batteries were tested at the dealer aprox 2 weeks ago during a free diagnistic check up. the main start batterie was perfect and the accessary baterie was starting to go south but still good at the time...The car is supposed to use the Main/start battery to start so it shouldnt be dependent on the assecary bat. Right now all the accesary work fine, headlights are BRIGHT but just in case i put the accesary bat on trickle charg 2 amp over night, still NO start. When the problem happenned the car started no problem, ran fine, i backed it out of garage, washed it and now it wont start anymore...had to push it back in garage.
 

·
R.I.P Always Remembered
Joined
·
1,865 Posts
If you can hear it click when you try to start, then power is reaching the starter so either insufficient power or bad starter motor/bad connections.
 
1 - 4 of 4 Posts
Top